Slow updating portage cache

I guess I’ve been using Gentoo now for just a little over a year.It’s quite nice in my opinion, and have multiple servers running it.The server locations are defined in the following variables: GENTOO_MIRRORS defines the list of servers that contain source packages (called the "distfiles"). A third variable contains the name of the server Portage use when you synchronize the tree: SYNC defines the server used to synchronize the Portage tree.Variables GENTOO_MIRRORS and SYNC can be set automatically by the program app-portage/mirrorselect .Integration options When Portage has merged a newer version of a package to the system, it removes files from previous versions.Portage gives the user five seconds to oppose the deletion of these files.You must install it with the command emerge mirrorselect if you intend to use.You can consult with app-portage/mirrorselect with the following command: mirrorselect - help If you must use a proxy server, you must specify its name in the variables HTTP_PROXY , FTP_PROXY and RSYNC_PROXY .

A file that should be installed in a protected location is renamed and the user is warned of the presence of a new configuration file.

Download tools When Portage needs to fetch source of a packet, it uses wget by default.

You can use it with another command variable FETCHCOMMAND . It also uses the command wget by default, but you can change that with the variable RESUMECOMMAND .

Executedemerge --oneshot portageeix-sync And I get the results below. Do I need a a later gcc for libreoffice compile/update ? Should I delete as instructed ........../var/calculate/remote/packages/CLDX/x86_64/media-libs/mesa-9.1.2-r1.tbz2..........&........../var/calculate/remote/packages/CLDX/x86_64/x11-libs/cairo-1.10.2-r3.tbz2......... Lastly I don't see a later gcc available then 4.6 as shown for Libre Office error checking I see Reading category 159|159 (100%) Finished Applying masks .. Invalid binary package: '/var/calculate/remote/packages/CLDX/x86_64/media-libs/mesa-9.1.2-r1.tbz2' !!! [ ok ] * Messages for package app-office/libreoffice- * Compilation with gcc older than 4.6 is not supported * ERROR: app-office/libreoffice- failed (pretend phase): * Too old gcc found. I am interested in knowing the why as I have used the Gentoo spinoff Sabayon for Years but not with portage. I now seem to have my emerge update world corrected. I had worked with portage as long ago as 10 years but did not stick with it.

Database contains 16695 packages in 159 categories. 16695 packages) * Time statistics: 2 seconds for syncing 18 seconds for eix-update 1 seconds for eix-diff 249 seconds total calculate sqlpython # emerge -u Dav world !!! * Working directory: '/usr/lib64/portage/pym' * S: '/var/calculate/tmp/portage/app-office/libreoffice-' Running pre-merge checks for net-libs/webkit-gtk-1.8.3-r201 * webkit-gtk-1.8.3-r201.tbz2 MD5 SHA1 size ;-) ...

Search for slow updating portage cache:

slow updating portage cache-16slow updating portage cache-6slow updating portage cache-49slow updating portage cache-1

After reading a few pages, I found this page which has an interesting suggestion on the second posting.

Leave a Reply

Your email address will not be published. Required fields are marked *

One thought on “slow updating portage cache”